Xbox 360 subtitles and windows 7

There is one little problem with number 10. There is no Trancoder-option in the newest Tversity (only General, Media Library and User Account). But anyway, I got it working with these instruction! Thank you!

I write shortly what i did to get this work with Win 7 (64bit) (did the same as fxandrei and deusofhearts)

1. Delete all your earlier attempts to install Tversity, codecs etc…
2. Download and install newest Tversity without Tversity coced pack (remember to remove the V-sign!). After installation, don’t start the process and don’t open the program (remove those V-signs in the final step of the installation before clicking Finish)
3. Download and install CCCP http://www.cccp-project.net/ but don’t install

  • FFDShow Tryout
  • Haali Media Splitter
  • VSFilter
    4. Download and install FFDshow-tryouts http://ffdshow-tryout.sourceforge.net/ with default settings.
    5. Download and install MatroskaSplitter http://www.free-codecs.com/download/Haa … litter.htm with default settings.
    6. Go “Run” and open service.msc (if you’re using win7 with default settings, you need to add ‘Run’ to your start-directory at first --> Google it how to do it!). Find TVersityMediaServer and double click it. Go to Log on -tab, select This account, then add your username and password. Click Apply and Ok.
    7. Start TVersityMediaServer -service by clicking right button on the service and choose “Start Service”.
    8. Choose Start > All Programs > ffdshow > Video Decoded Configurations
  • Mark Subtitles from the left (put the V-sign!)
  • Choose Subtitles and on the righthand side check that you have V-signs in the following places:
    ----Accept Embedded subtitles
    ----Accept SSA,ASS, ASS2…
    ----Decode closed captions
    Then click OK.
    9. Open Tversity
    a) Go to the Settings tab
  • General tab: Media Playback : Autodetect
    b) Go to the Library tab
  • Add your video-directory ("Add item") and when adding it, before clicking submit, open the Advanced tab and change default setting to Transcode: always.
    10. When using subtitles, name it as same as movie is named, e.g.:
    MyDog.avi
    MyDog.srt

Thanks to deusofhearts and fxandrei.

I made an edit.
U must not install the drivers included in the tversity instalation.
This is very important.

Im giving up with tversity… So many wasted hours… Could you please write how did you manage to get subtitles to work with PS3 media server? (.srt + .avi)

Trying to get .srt + .avi to work with Tversity is way too complicated - there are as many instructions/tips/hints as they are users. Many different ways to get it work, but finally they work only in some cases. Usually not. I have tried these several guides, but none of those worked. So i just give up with tversity!

What i did, was…

  1. remove everything (even tversity)
  2. Downloaded CCCP http://www.cccp-project.net and installed it with the following items UNSELECTED :
  • FFDShow Tryout
  • Haali Media Splitter
  • VSFilter
  1. Installed FFDshow-tryouts with the default settings, didn’t change anything.
  2. Download and install MatroskaSplitter with the default settings, didn’t change anything.
  3. Installed Tversity without fff… and codecs.

And the result was:

Unplayable Content
Can’t play this content because it may not be supported.
Status code: 69-C00D36C4

I think i got this message because i tried to install Tversity without the ffd… and codecs in main setup of tversity.

So, I have one question, in which “number” did you installed Tversity? Was is already installed before you removed all the codecs etc and installed all the other or did you installed Tversity after the others? You didn’t mention anything about installing Tversity. And when you installed Tversity, did you installed also the ffdshow/codecs with the main setup?

hallelujah

thank you. i believe that the part i was missing was the tverity log-on information.

Registered to make this reply;

Thanks a lot, somehow it all works now.

1 Thing to point out, I think I installed Tversity WITH the codecs, however it still worked for me.

Thanks a lot!

Hey. So, i did everything the guide said, but i havent been able to get this to work. problem at step 8:

[quote]8. Started the services manager (Start- Run - "services.mcs", hit enter)
Went to the tversity service , went into properties, log on tab, selected "This Account" and selected my account, and entered the password for it.[/quote]

I can’t find “services.mcs”. Where does this “services.mcs” come from? Is it the same thing you activate to share the content on TVersity? And where do i log in whit my windows account? i’ve already added the password to it. In TVersity Settings, there is a section called User Account, but something tells me that i’m doing it wrong. :(

i’ve done everything else. all of the steps. I can even access to TVversity media server in my x360 but it does no transcode the files and it doesn’t show any subtitle.

I am kind of a noob in this, so i would really apreciate your help. :mrgreen:

I apologize for any writing error, but i’m doing my best as far as i don’t handle english lenguage perfectly.

cheers from venezuela :D

If you aren’t transcoding, you have to force TVersity to do it. Make a new Library folder to hold videos that NEED it, set it to Always transcode, and keep the videos there…

It’s services.msc, typed into the Run box…

thanks mikepaul, but anyways it is still not transcoding any video. maybe i’m streming in a wrong way, idk? how do you guys exactly stream the videos into your 360 to have subtitles? I go to Video library on my dashboard, then i select Tversity on MYPC and browse to slect the video. i checked tversity STATUS wile streaming a video and there is nothing in the Transcde section.

WHY? :(

Well, I am now on step closer hahaha :( it transcodes, as you can see in this image:

but it doesn’t show subitles D’: what coauld be the problem now?

You probably need to change how TVersity is run. Ffdshow often doesn’t pick up the subtitle-related directions when called from TVersity because TVersity is running under a System account. You need to follow the directions here to have TVersity wrk better with ffdshow once you make sure subtitles are on…

Nice! i don’t know how, but subtitles are now working xD…

Thank you mikepaul, i really appreciate your help… :D

last thing :oops: how can i stream mkv’s? i’ve seen a few topics talking about but nothing concrete. how do you do it? how good is the video quality of a video on 720p after transcodig with subs?..

720p MKV is the same as any transcoded video when it comes to streaming, but the more you make the server work to create the transcoded version, the worse the playback goes.

Setting TVersity to make a real 1280x720 output will pretty-much guarantee that the video will pause often when the output isn’t made as fast as is needed, probably 30 frames per second. Since the 360 will upscale whatever it gets to fill the screen, you can aim for a smaller size, maintaining the 16:9 ratio like 640x360, and see how it goes. Of course, ALL videos will take this size so you’d have to change it when playing stuff that isn’t at 16:9, like 720x480 SD videos.

If you find nothing works well, the best move is to convert the video to MP4 or WMV so it won’t need transcoding. That’s more work than most folks playing MKV want to do, since they, ummm, ‘found’ the video and just want to watch it, but that’s the way it goes until Microsoft relents and supports MKV and the most popular codecs stored in a MKV on the 360.

That will not happen soon…

Step 8 & 9 worked perfectly for me.

If anyone else is having the same problem, what you might want to do is create another folder within tversity with just the subtitled films in, then set the option on that to always transcode. That way it only transcodes for films with subtitles in which is what you need to do to get subtitles to work. I personally don’t like it transcoding because it takes longer to stream and there’s a performance hit on my pc.

I already had all my foreign films in a folder called inventively…"foreign films" so although the parent folder was already added, I just added another within tversity and did that…works like a dream.

I figured out what my problem was and made an account to share what I found. A few of the posters before me mentioned it was only working on videos that had separate subtitle files. I was having trouble getting the subtitles of .mkv files to show up. To get them to show up I followed all the steps outlined by the original poster. What I did extra was extract the subtitle file out of .mkv and made sure they were named the same like another poster suggested.

Example
MovieABC.mkv
MovieABC.sbt

Here is a link to the guide I used to extract subtitle files out of an .mkv
http://www.dvd-guides.com/content/view/157/59/

Hope this helps someone.

Ok so, the new Tversity version broke my transcoding.

No .srt file gets transcoded whatsoever, I didn’t change anything, just downloaded the new version, installed it, boom: no subtitles…

Did the new version wiped my settings or something?

Anyone can think of a solution?

Ok, add transcoding in Tversity, Windows Media Encoder was set back to Windows Media Video 8

I seriously never changed anything because i was already so freaking happy when i got it to work due to this awesome guide.

I changed it back to Windows Media Video 9, restarted the service, refreshed my library and it worked again

This also works:

Tested on Windows 7 Professional x64, with TVersity running as an admin user. Not sure how important this last bit is. Please post an update to this thread if you get this working with TVersity’s default System user.

. Uninstall any existing codec packs and TVersity
. Install TVersity 1.9.3
. When the TVersity installer states that ffdshow is missing, install K-Lite Codec Pack 6.6.0 Basic
. On the K-Lite installer, allow the pack to handle all video formats (select all)
. Complete the TVersity install
. In TVersity’s settings:
. Media Playback Device: Auto Detect (default)
. Transcoder: When to transcode: Always (or set this on the folder that contains your files with external .srt’s so you don’t add the transcoding overhead to all your video files)
. Transcoder: Windows Media Encoder: Choose any of the Windows Media Video options (subtitles won’t work with the MPEG option)

This doesn’t enable embedded subtitles in MKVs though.

is it possible to display subtitles when streaming internet videos?
I’m streaming from megaupload and have the srt file but I don’t know how to make it work.

thanks in advnace

I point that out occasionally but repeating it is a good idea…