Xbox 360 subtitles and windows 7

So to start things off i just want to add that its been a while since i was trying to find a good solution to play movies on my 360.
First i tried tversity but i wasn’t able to get subtitles to work at all.
I tried again and again all sorts of things but nothing worked.
Eventually i found the ps3 media server which had subtitles “out of the box” but the problem with it is that it wasn’t all that good for the 360; it worked, but it was sluggish.
So i decided to give tversity another go.

So googled quite a few hours and eventually found this : http://forum.tversity.com/viewtopic.php?f=24&t=10517.

So let me describe my situation.
I have Windows 7 and i had klite codec pack installed.
So this is what i did :

1. Uninstalled everything that was related to codecs : klite codec pack, ffdshow, avisynth, etc . I simply uninstalled everything i found that had something to do with video conversion or codecs.
2. Ran Advanced System Care 3 and cleaned my registry.
3. Restarted my pc.
4. Added a password to my main windows user account (the one i use). VERRY IMPORTANT (IT SEEMS THAT THIS IS THE ONE I MISSED THE OTHER TIMES I TRIED TO MAKE SUBS WORK)
5. Downloaded CCCP http://www.cccp-project.net and installed it with the following items UNSELECTED :
- FFDShow Tryout
- Haali Media Splitter
- VSFilter

6. Installed FFDshow-tryouts http://ffdshow-tryout.sourceforge.net with the default settings.
7. Download and install MatroskaSplitter . http://www.free-codecs.com/download/Haa … litter.htm
8. Started the services manager (Start- Run - “services.mcs”, hit enter)
Went to the tversity service , went into properties, log on tab, selected “This Account” and selected my account, and entered the password for it.
9. Went to : Start > All Programs > ffdshow > Video Decoded Configurations ,scrolled down to subtitles and checked subtitles and then made sure these are CHECKED :
- Accept Embedded subtitles
- Accept SSA,ASS, ASS2…
- Decode closed captions

10. Open Tversity, make sure the service is running , add movies and the go to settings and make sure these are set :
- General :
- Media Playback : Autodetect
- Transcoder :
- When to transcode : "Always"
- Windows Media Encoder : i had checked "Use Directshow …"and "Windows Media Video 9" selected in the combo
EDIT : When u install TVERSITY MAKE SURE U DO NOT INSTALL THE DRIVERS included.

I finally went to the 360 and voila : subtitles :D.

this doesn’t work for me

my problem seems to be that ffdshow isn’t used for mkv files. the try icon isn’t there and i checked this by turning on OSD, if i watch an ogm i get the OSD and the subs work, but not with an mkv file. and this isn’t even on the xbox itself, i already have this issue when i play the videos on my pc. do you have any ideas?

btw i think i have a solution to the password issue, but first i want to get it running (just to make sure i’m using a password for my account atm)

edit: i’m running windows 7 home premium x64

edit2: ok, i got it working now, somehow, i don’t know how but i won’t touch it anymore. I still don’t have subtitles (or the ffdshow try icons) when playing the files with media player, but they work on the xbox (and when running the file using tversity). If i want to watch something on my PC i’ll just use VLC so i won’t have to touch my codecs anymore

Hi,

The only way I have been able to get subtitles to work is to hard code them in using Videora Xbox 360 Converter.

My pretty simple guide. :P

Hope it helps ya,

Will

[quote]Hi,

All right here is how I got subtitles working on my xbox 360 for my HD 720p and HD 1080p .mkv videos.

You Can Skip This Part, Just Friendly Tips:

First make sure you have the latest xbox 360 dashboard updates:

http://www.xbox.com/en-US/support/syste ... pdates.htm

So you do already have your subtitles right? That is the .srt file for the video? No?

OK well download the correct one from:

http://subscene.com/

Or if you can’t find it there and your file already has subtitles “built into it” such as .mkv files, then you first need to extract the subtitle information in the form of the .srt file using:

http://forum.doom9.org/showthread.php?t=152108

Or using: http://www.videohelp.com/tools/MKVExtractGUI

Tip: You can use MP4Creator to extract subtitles from MP4 files:

http://mp4creator.sourceforge.net/download/index.htm

So make sure the video file and the .srt file are named the same and in the same directory. Must be!!!

For example have these two files in the same directory:

video.avi
video.srt

By the way I highly recommend you name all non divx files as .avi so that the xbox 360 will see it. XboX 360 for example will not see .mp4 or .mkv files.

Tip, use XenonMKV to get .mkv files working on your xbox 360:

http://xenonmkv.ev98.net/

Then follow my guide after converting the .mkv file to .avi .

Now we are ready to get our subtitles working:

Note that the subtitles are going to be "burned into" the video, which means you can not turn them off.

"Burning" the subtitles into the video is the only way you can get subtitles working on the xbox 360. Blame Microsoft for this!! Anyhow…

1.) First lets open Videora XboX 360 Converter and turn off the subtitles option for the profile you wish to use. Do this for all the profiles you plan on using for the xbox 360.

You will see why later, basically we are going to use more advanced software for our subtitles.

If you don’t turn this option off, you will get double subtitles, that is the subtitle text will be shown on screen twice, merged together as one. Meaning the subtitles will be unreadable and useless. So pay close attention.

So turn this option off please:

Settings > Encoding > Edit Profile > Video > General 2 > Uncheck "Subtitles"

2.) Download and install http://www.free-codecs.com/download/K_L … c_Pack.htm, the standard version is all you need.

If have have another codec pack installed remove it first and reboot PC and then do this step. Just install using default settings. Reboot after installing this codec pack.

3.) So now after you have rebooted the PC (you must have or this will not work, so reboot now if you have not yet, don’t waste your time and mine troubleshooting please)…

We now turn on subtitles in ffdshow video decoder. So open ffdshow video decoder from the start menu:

start > all programs > K-Lite Codec Pack > Configuration > ffdshow video decoder

4.) Switch to subtitles on left side bar in ffdshow video decoder. Check the subtitles box to enable subtitles. And make sure these options on the right are checked (enabled) as well:

Process whole image
subtitles
search in
accept embedded subtitles
accept ssa, ass and ass2 subtitles (experimental)
decode closed captions

5.) Switch to Font on left sidebar in ffdshow video decoder under subtitles. Check the "autosize" check box and then click OK button on the bottom to save our settings.

Note: This makes the subtitle front huge and might be too big for your tv, if it is then change "Body" under "Size, Colors & Alpha" to some other size.

Notice when you enable "autosize" it sets it to 60, so perhaps try something like 40. Also, notice it was 26 by default.

OK, so at this point the subtitles will now work. But the problem is we will get double subtitles. Whoops, so lets fix that.

6.) Open Haali Media Splitter from start menu:

start > all programs > K-Lite Codec Pack > Configuration > Haali Media Splitter

Switch to "Options" tab. Open "Compatibility" and then "Autoload VSFilter" and then set its value to "No" and click Ok to save our settings.

OK almost got subtitles working correctly now, almost done, I promise.

  1. Open DirectVobSub from the start menu:

start > all programs > K-Lite Codec Pack > Configuration > DirectVobSub

Switch to the "Misc" tab and check under "Picture Output" > "Hide subtitles" and then click ok to save our changes.

All right no more double subtitles.

Good to go, transcode away my friend with all those lovely subtitles of yours.

Glad to help you out if you run into any problems. I’ve only tested this myself on Windows Vista SP2.

Enjoy,

Will[/quote]

hi mister,

i am running win7 home edition, having TVersity and Xbox360 Elite and i have tried your setup, it didnt work and also i have tried setup of your source dealing with Vista but in case that i didnt install TVersity codec, it didnt played mkv at all, not sure about other formats.

has anyone veeery detailed tutorial how to run subtitles on Xbox using TVersity?

i am not happy that TVersity developers didnt launch any information how to run it, all i can see r the tips and hints how to run it seeing that many of them wont work. anyone?

Transcoder is still there. You need to scroll…

Finally got subtitles to work thanks to this thread!

I don’t understand why part 4 was needed (Added a password to my main windows user account (the one i use). VERRY IMPORTANT (IT SEEMS THAT THIS IS THE ONE I MISSED THE OTHER TIMES I TRIED TO MAKE SUBS WORK)) But thats what got it to work!

CAn I use this guide on windows xp too?

[quote="fxandrei"][/quote]

Hey fxandrei. I followed each step that you have taken and for some reason any video that I choose to watch now I get the following error after at the top of my TV screen the bar appears and says opening, then it says:

Unplayable Content
Can’t play this content because it may not be supported.
Status code: 69-C00D36C4

This happens now to all of my videos, even the ones without subtitles which worked fine before I followed the steps you listed.

Any help would be greatly appreciated!

I have registered in this forums to say this:

You’re my hero men really!!! I tried this and it works everything!!! Avis with srt subtitles and also MKV movies!!! :D

Thank you so much!!! :mrgreen:

Great. :D
I also need to mention that i had help from here http://forum.tversity.com/viewtopic.php … dd9792b47e ;).

Before I make this a sticky, can someone else verify its value?..

i just wanted to mention one thing .
i tried quite a few time to make subs work in tversity, but never could.
this time it worked.
and it works great.
the only real drawback is the fact that it transcodes everything, even stuff it can read natively (like wmv), but its ok :).

With no subtitle support built into the 360, you HAVE to transcode and include them…

u should check if u have set to always transcode and check if u have the neccesary codecs.
mind u that i tried quite a few time before it worker, but maybe it was because i hustled every time and i forgot about some setting or the codecs.
try to do all those steps again.
it really should work.

Step 6 fails for me with "The service did not start due to a logon failure."

And of course I’m sure user name and password are correct, otherwise I could not even logon to my PC.

Command style is same thing:

[quote]
sc start TVersityMediaServer

[SC] StartService FAILED 1069:

The service did not start due to a logon failure.[/quote]

OK, looks like a step is missing, as found in event viewer:

[quote]The TVersityMediaServer service was unable to log on as .\Will with the currently configured password due to the following error:
Logon failure: the user has not been granted the requested logon type at this computer.

Service: TVersityMediaServer
Domain and account: .\Will

This service account does not have the required user right "Log on as a service."

User Action

Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.

If you have already assigned this user right to the service account, and the user right appears to be removed, check with your domain administrator to find out if a Group Policy object associated with this node might be removing the right.[/quote]
OK, so first you run Secpol.msc from start > search or start > run.

Then open Local Policies > User Rights Assignment > Log on as a service

Click the "Add User or Group…" button. Then click the "Advanced…" button and then the "Find Now" button and find your account listed and click the "OK" buton. Then "OK" again. Then "OK" once more.

Then lastly start the TVersityMediaServer service. Will start just fine now.

:lol: Oh yeah, it's there.. Just needed to make the window larger :mrgreen: (Feeling a bit stupid!)

Just wanted to add another confirmation. By following these steps as described in the first post, I also got the subtitles working!
I’ve been trying numerous other similar guides and the only thing that seem different is the user login part for starting the service.

I’m running Win 7 Pro 64-bit and it’s working like a charm!

Thanks a bunch for sharing! :wink:

Following the instructions in this thread, I was able to get subtitles to work with an external .srt file only. I’ve confirmed that the transcoding is using ffdshow (and my current account’s settings) by turning on OSD with a couple things shown. The OSD is present when I watch the files in MPC, WMP and when I stream to my 360. The embedded subs are there (and will go away if I turn off subs in the ffdshow config) when I watch the files in MPC and WMP, but are not present when I stream to my 360.

Any ideas?

Edit: A bit of additional information in case it’s important: I’m running Windows 7 Enterprise 64 bit.

About the password issue:

I wrote a little guide concerning how you can make it work without a password. But i suggest you first get it running using a password and then remove the password restriction. I’m posting it here so that people who use this guide to get the subtitles working also find the way how to remove the password

Here is the guide: http://forum.tversity.com/viewtopic.php?f=24&t=49148

I tried like everything… but even this is not working…
I performed every step in this tutorial… but it is not working

I can get video’s (not MKV files) but i just cant figure out how 2 get the subs in there…

Can someone please help me out! u can pm me or put it in this threat

THNX!