What's the status with subs with RC1?

Hello there…

Can anyone say if they had any success with subtitle streaming with RC1? previous versions were hopeless for me…

Thanks!
T

It’s working!

I just want to let out a big thanks to Aesti/Telv for the hints in this thread. I got subtitles working for the first time in years and I’ll explain how I got it set up.

In TVersity’s settings:
When to transcode set to Always. - If not, TVersity never trancodes now that the 360 is playing almost all formats. No trancoding - no added subtitles.
Windows media encoder set to Use DirectShow and them WMV8 selected in the dropdown - For some reason ffmpeg does something weird to my files and the Xbox can’t play them.

Then make sure (sorry if I’m repeating what you said earlier Aesti/Telv but I just want to catch all steps here) the TVersity Media Server service is running LOCAL SYSTEM. A lot of you out there probably have it set to Administrator since that solved some earlier problems TVerstity had. Just go Control Panel / Administrative Tools/Services and right click Properties on the TVersity Media Server service to change this.

Install DirectVobSub and start a movie with subtitles locally on your computer and have Windows Media Player play it. From there right click the task bar icon and change settings to Always Run.

There, that should be it. Once again big thanks to Aesti/Telv. I’m one happy camper.

But… I thought that vobsub caused problems, and you should do it with FFDShow?

UPDATED! - You don’t have to kill off DirectVobSub!

Ok… I’ve completed my tests with RC1…

If you never got subs before, RC1 won’t help you.

However, based on the other information provided in this forum, I have figured out why subtitles do not show.

Subs won’t show under the following conditions:

  • Directvobsub is installed
  • Haali is installed with vobsub set to autoload
  • !IMPORTANT! you have another video steam decoder decoding the video instead of ffdshow

DirectVobsub is the reason why no subs show up. In its default configuration does not do anything when tversity transcode.

The next thing has to do with the video stream. With Haali now no longer doing anything about the subs, if you had something else decoding the video (eg CoreAVC, xVid) instead of ffdshow, then ffdshow VIDEO filter won’t load (duh!). No ffdshow = no directshow processing for subs.

So you have THREE options:
a) kill off DirectVobSub and those other pesky video decoders and let ffdshow decode everything
b) enable ffdshow to process RAW video (disabled by default). This means that ffdshow video decoder will load no matter what video is fed in.
c) !NEW! fix up DirectVobSub’s configuration, you go into DirectVobSub’s properties (not the runtime one; check your start menu or do rundll32.exe VSFIlter.dll,DirectVobSub). In the General tab, change Loading to Always Load

Debugging this process can be a lot less painful if you find a copy of Graphedit (graphedt.exe) and have it render the DirectShow graph.

Hello,

Thanks for the information you provided. Right now it seems I’ve got more basic connectivity problems with my 360 (which ports are supposed to be opened after all? argh!), but I think that the last time I checked I had both Directvobsub (though ffshow was the default decoder) and Haali installed. So I’ll try and see what happens…

Thanks again :)
T

A bump to indicate a thread update. See update in 2nd post above.

The last few subtitle tests I did with the LAST version of TVersity did work with ffdshow. Vobsub had issues. Perhaps things changed…

Hi, it is actually Telv here (my email host hates the emails from this new forum software).

Did you enable ffdshow’s option to process RAW video? If not, unless ffdshow is the one decoding the actual video you won’t get subs. ffdshow does not load by itself if it only has to do subtitle decoding

[quote=“Gryzor”]
Thanks for the information you provided. Right now it seems I’ve got more basic connectivity problems with my 360 (which ports are supposed to be opened after all? argh!), but I think that the last time I checked I had both Directvobsub (though ffshow was the default decoder) and Haali installed. So I’ll try and see what happens… [/quote]

Did you try Option C on my (Telv’s) post? If you want directvobsub to do the job you must tell it to load no matter what. If directvobsub’s configuration is user dependant, then you may have to do run the tversity service as yourself instead of localsystem

After reconfiguring my decoding setup to use ffdshow exclusively, I’m still unable to stream subtitles to the Xbox. Everything looks great when I build and preview the graph in Graphedit, and the streamed video and audio are fine except for the missing subs.

DirectVobSub is installed, but not in use. Haali is installed but not loading VobSub–I set VobSub to never load after getting identical results on the other two loading settings. Graphedit is telling me that ffdshow is the only decoder in use. Ffdshow has subtitles enabled and VobSub disabled.

Any thoughts? Is there any further information I can provide that might help with a diagnosis?

Sorry for the double post, but one more thing that might provide insight:

I can’t seem to open TVersity’s graph in Graphedit, neither when it’s streaming nor when it’s trying to play video in its library browser. In fact, MediaServer crashes when I try to play (apparently) any MKV at all.

I wonder if we are to ever see a solution to this; in other words, how high is this issue in the dev to-do list?

It’s a real shame, because it’s an excellent program that I cannot use… :(

Make sure the Tversity service is running as the same user as you.

My sincere apologies about taking so long to respond. If I were to enable RAW decoding with ffdshow, would I do that by going to Codecs > Raw video in ffdshow’s video decoder configuration and setting that to “all supported”? If so, that is what I did, but I’m still not seeing subs on the Xbox. They do, of course, still work in Windows. Is there any other way to make sure that TVersity is decoding using ffdshow?

ffdshow’s subtitle module still has some issues with things like accents (or whatever you want to call those things). DirectVobsub works! but as Hoffe mentioned, you MUST set it to Always load (you can find this at the bottom of the General tab of DirectVobSub).

If you have DirectVobSub and not seeing subs on your 360, it is usually because it is not loading.

I’ve been having a hell of a time trying to get the subs to load… it’s like TVersity doesn’t want to connect the text pin to FFDShow OR VSFilter (DVobSub) . Either should work fine. I have ZERO problems gettting VSFilter into the filter graph for TVersity; however, it NEVER connects the text out pin from haali to the in pin on DVobSub, only the video pin from ffdshow; changing auto-load settings in either haali or vsfilter seems to have no effect. Same problem when I set the subs to FFDShow; windows media player and all other directshow players render file 100% fine and in FFDShow, but the text pin is not connected to FFDShow.

I’m 100% certain of my conclusion regarding the text pin being left floating for the following reasons:
[list]
[]When TVersity transcodes, the filters are always present in the system tray.[/:m]
[]Altering settings on VSFilter with ‘autoload’ enabled in haali will alter the output on my 360 (Flip video, show OSD statistics)[/:m]
[]Altering settings on FFDShow with ‘autoload’ disabled in haali will alter the output on my 360 (Show OSD)[/:m]
[]In the VSFilter config dialog in WMP, I can see “English (ASS)” under “Language”[/:m]
[]When running off of FFDShow in WMP, I get an additional option in the context menu called “Subtitle Source”, which displays a disabled option “Embedded (ASS English)”[/:m]
[]Running off of the TVersity transcoder, the dropdown box in VSFilter under “Language” is BLANK, and there is NO option named “Subtitle Source” in FFDShow’s context menu – This behavior is reproduceable by disconnecting the text pin in graphedit in both cases.[/:m][/list:u]

The files I’m trying to view are matroska video with h264 video, aac audio, and embedded .ASS format subtitles.

Which versions are you using (media player, tversity, vob, ffdshow,…)?
I’m struggling as well…

This discussion is closed.