TVersity won't show on Xbox360 & "Cannot Extract Package"?

Okay so I am having two issues currently with TVersity. The first being my Xbox360 is not showing TVersity at all and the 2nd being TVersity when I try to run it from my computer says it “cannot extract package”. I was going to see if any of the configuration settings needed to be reconfigured but I cannot do that seeing as I cannot launch the program. Any ideas how to solve both my issues?

Well idk what did it but reinstalling it made it possible for me to launch the program. Afterwards I did a bunch of things on my computer so TVersity would get recognized by my Xbox360 and I have it working.

Here are things I did incase someone else has the same problem… Like I said though idk what worked so try all that you can.

  1. I went into services.msc and disabled the Homegroup Listener and Homegroup provider service.
  2. Since I have a Dell PC I uninstalled Dell Data services and some other Dell program.
  3. I have Windows 8.1 so I went into “PC Settings” > PC and Devices > Devices > Add A Device
    I searched and it came up with TVersity… Later on though this disappeared so I don’t think this step is necessary.
  4. I went into Windows Media Player and enabled media streaming.
  5. I went into Windows firewall and opened port 41952 for TVersity and all ports for my Xbox360
  6. I went into “Network And Sharing Center” > “Change Adapter Settings” > Clicked ALT on my keyboard to show the menu and clicked on “Advanced” > Advanced Settings > I then reordered my network so it went VPN > ethernet > Wireless (my VPN says Local Area Connection)

After all this I restarted my PC and low and behold it finally works. I may have missed a couple things I tried. I will add them later if anything comes to mind. I hope this helps someone else out in the future.

Thanks for sharing and glad it all works.

I think the crucial pieces is the ordering of network adapters and firewall configuration. While TVersity configures the Windows firewall automatically. Other firewalls will need to manually configured by the user.