How to get subtitles to work

Subtitles only work for transcoded videos (and transcoding is supported only in Pro version). TVersity relies on ffdshow to decode the subtitles while the video is being decoded and then it burns them to the video. This allows subs to work with any device (even those that do not support subs) as long as the video is being transcoded.

So here is what you need to check when the subs do not show up:

  1. Make sure TVersity transcodes the video - you can verify it by looking at the status page. You may need to force transcode if it is not being transcoded.
  2. Make sure you have ffdshow (32 bit and latest version) installed and subs are configured as per the screen shot below. If it is not installed then install it and then re-install TVersity.
  3. You may also need to run TVersity from the command line as per the instructions below, this is instead of running as a service.

Required ffdshow configuration:

Instructions for running TVersity from the command line:

  • Stop the sharing service and wait till it is full stopped
  • Open a command line windows with admin rights (cmd.exe)
  • Go to the folder where TVersity is installed (typically \ProgramData\TVersity\Media Server)
  • Run the command:

MediaServer.exe -DEBUG

Hi. Even after read this post I can’t get subtitles to work. I did all the steps. May the problem resides on the fact that my tversity do not transcode, even after I set “always” in the Transcoding menu and run the command line.
My Tversity in version 3.5 Free. OS Windows 8.1. Only ffdshow installed.
I was trying to watch on my LG 46LA6610, but I run tests with chromecast too (assuming that the subtitle will work on chromecast).
One more question: I already had Tversity when installed ffdshow 32 bits, and then I re-installed it as mentioned. Is that the right way, or should I uninstall and install it again?

Pro is required for transcoding so subtitles are NOT supported in the free version!

Oh, shame on me, I didn’t notice this on FREE - PRO differences. Anyway, knowing it now will save me a lot of time.

Thanks ^^

Dear Rone
I have The Pro Version two days ago and I followed your instructions and asked media server to always transcode but I noticed after launching a file that the in status windows and the transcode tile there is nothing mentioned about any trans coded session although I Forced the Application to transcode
I need Subtitles to work Asap pls

What device are you using on TV? If it is not supported and identified (check status tab) then setting system to always transcode won’t have any effect.

IT is a receiver which has dlna dmp enabled ,and it is being identified as web device
everything is ok except for the subtitle
pls help me solve the problem although I have followed all the previous instructions

Identified as web device is the issue. Our list of supported devices is at:

I seem to have the exact opposite problem :frowning:

I DONT want subs and even with Subs disabled in FFDshow and Transcoding Disabled, my LG TV’s show subs, but my PS3 and iPad/iphone don’t…

The difference between devices is due to the fact that the TV gets transcoded content while the other devices do not. So the issue here is to make sure transcoded content does not get subs. The easiest fix would be to remove the SRT files from the folder where the videos are, is that a possibility for you?

If the Subs are embedded in the source like MKV for example I get them forced :frowning:

Older version of LG can turn them off on demand, but on WebOS 2 they are on even with the setting “off”.

Having a disable Subs in the TVersity UI would be more robust solution.

Are these videos transcoded? If so, you disable the subs via ffdshow. If non transcoded then indeed it is a function of the LG TV.